This document is an example assignment that will help you understand
how to use Revit. Use it as a guide for your supermarket. If you have any
further questions, ask a TA.

1. Open Revit

2. Select the Wall Command
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3. Using the mouse, draw a rectangle of any size between the four elevation
arrows, like this:
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Note that the “home plate” trapezoidal shaped objects are Revit's (unusual) version of
an elevation key (where the arrow is pointing). Revit always starts out drawing a
building with two “levels” (floors), although you can change the number of floors by
adding more levels.

4. Click on the right wall. Note that a temporary dimension will appear.
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5. Click on the dimension and change it to 60 by typing in 60.
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6. Do the same for the vertical dimension by clicking on the bottom wall and type
in 30:



7. The plan will now look like this:
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8. You will have a 30’ x 60’ building plan. This is the beginning of our house.

9. Click on the 3D icon that looks like a house in the upper line of the tool bar:
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Your house will now look like this:

The symbol in the upper right corner of the screen is called the “view cube” where the
arrow is pointing toward. This is a sweetie of a tool because it will allow you to navigate
to different views of the 3D object. Remember in Revit, you are drawing in 3D all the
time. The view cube appears whenever you are in a 3d view.

Let’s experiment with the view cube.

Click on the word “TOP.”



This is what it will change to:

It looks like a plan, but it is really a 3D view looking down.

Now click on a corner of the cube. This is what it will change to:



Now click on the word “FRONT” on the view cube. This is what it will change to:

FRONT

Hover your cursor over the picture of the house above the view cube and click on it
with the mouse. This is what it will now look like:

The view cube will only appear in a 3D view, not in a plan, elevation or section —
these are 2D views of your model.

You can zoom in and out in any view by moving the mouse wheel forward or
backward. Try it!



You can “Pan” the object to left or right or up or down in any view by simply holding the
wheel down and moving the mouse back and forth. Try it!

Much drawing work in Revit can and should be done in a 3D view. When you are in a
3D view, you can turn the view around and look at it from different sides by holding the
Shift key on the keyboard down and holding the mouse wheel down at the same time
and moving the mouse around. Try it!

10.Let’s go back to the plan view. To do this, double-click on the words “Level 1”7 in
the Project Browser on the left hand of the screen. That means you are going to
the Level 1 (First Floor) view.
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This is how your drawing will now look:
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11. Let’s put a couple of doors into the building:

Click on the door icon on the Home Tab of the Ribbon:
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Turn off the “Tag on Placement” option on the Ribbon:
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This will not put a door “tag” symbol in the door opening. Door tags are used to
reference a door schedule, which we will create later on. To keep things simple, we will
just put the doors in for now and add the tags later.

This is how your building should look after placing a door:




The door may be the wrong size and may be in the wrong location, but that is easy to
fix later. You can move the door anywhere along the wall in which it was inserted and
you can change both the swing and the hand of the door. Let’s practice moving the
door along the wall. Select the door. Temporary dimensions will appear:

i -0” 50 -0°

Select one of the dimensions and change it to 20. This is how it will look:
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Hit an Enter key and the door will move over to 20’ from the wall, like this:

40 -0 20 -0

You can also move the door by clicking on it and holding the left button of the mouse
down and moving the mouse left or right.

Let’s say you want to move the door to another wall. To do this you have to select the
Pick Host tool on the Ribbon and select the wall you want to move it to:
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So if you want to move the door to the left wall, Pick Hose and click on the left wall
and the door will move there. It will then look like this:

Note that when you click on a door, it will show some arrows:

These arrows allow you to change the swing or hand of the door by clicking on them.



To change the swing, select the left-right arrows:

To change the hand of the door select the up-down arrows:

When you click anywhere else in the blank space of the drawing, the arrows will
disappear.



12.Install another door on the right wall. Make both doors swing in and center the
doors on the wall so they will look like this:

13.Let’s put windows in

On the Home tab, select the window icon.

Be sure to uncheck “Tag on Placement” again, just like you did for the doors. Hover
the cursor near the point you want to place the window and pick the left button of the
mouse. Hover the cursor toward the outside edge of the wall, not the inside edge. If a
window gets installed on the inside rather than the outside of the wall, you can easily
correct it by clicking on it and clicking on the arrows so the arrows are showing on the
outside of the wall.

Put in 5 windows on the bottom wall and 5 on the top.



At this stage, it is not important that they be lined up or have any particular
dimensions between them:

Let’s look at our masterpiece in 3D by clicking on the icon on the top of the ribbon
that looks like a house in 3D:
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The 3D view will now look similar to this:



14.Turn some shadows on to see is more realistically. To do this select the
shadows button on the bottom row of icons:
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This will be the effect:

15. Let’s turn some shading on to get even more realistic view:
To do this select the “Model Graphics Style” icon on the bottom row of icons:
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Select “Shading with Edges” style:

16.Let’s render the image. To do this select the icon that looks like a teapot with a
lightbulb next to it.

This icon image of a teapot has historic meaning within Autodesk products, as the first
rendering program created by Autodesk, 3D Studio Max, used a picture of a teapot to
illustrate its animation and rendering ability. Revit has this program built in.
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After you select the teapot, the rendering dialogue box will appear:
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There are several rendering and lighting options from which you can choose. When
you pick the “Render” button near the top of this dialogue box, Revit will produce a
photographic image that will look like this. Note that there is no ground shadows
here because there is no ground plane created yet.




You can “Export” the rendering to a “raster” graphics file such as a .JPG or .TIF or
.GIF file to put into a word document, post to a web site or send to someone to open
in their image viewer. .JPG files are files like those taken by a digital camera.
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To come back to the Revit model, click on the “Show the Model” button on the
bottom of the dialogue box.
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That brings you back to this image:

Close the rendering dialogue box, turn off the shadows, and go back to “Hidden
Line” visual appearance. Now your drawing will look like this again:
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17.Let’s get the windows spaced evenly. Go back to the Level 1 plan by clicking on
it in the Browser:
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Your drawing will look like this again:




Select the Annotate Tab on the Ribbon:
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Now select the “Aligned” dimension icon.

Start dimensioning by clicking on the left wall and then on each window centerline
by clicking on them one at a time and then click on the right wall, and then on a
blank area on the right side of the drawing. It should now look like this:

Note that there is an EQ symbol with a red slash through it above the dimension
string.




Click on that symbol with the left mouse button to turn it on:

This is the outcome:
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All windows will now move over to be equally spaced and the windows will be

“constrained” to this equality spacing regardless of whether the building is
lengthened or shortened.

If you now click on the EQ symbol again the windows will still be evenly spaced
and actual dimensions will appear:




You do not have to do this, but as an example of the equality constraint in action, if |
move the right wall 8'-0” to the right, thus lengthening the building, dimensions
between all of the windows will change from 10°.0” to 11°-4” maintaining the equality
spacing between windows.
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18. Let’s put some interior walls in the plan. Under the Home tab, click on the Wall icon.
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Note the Ribbon will change to look like this:
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This sub-ribbon contains options that you can choose for interior walls.

Select the “Change Element Type” button. A drop down list of various wall types will
appear. Select the Interior 5” Partition (2 hr) wall type and uncheck the “Chain” box.
Note that the Height for the new walls will change to “Level 2.” That is because you
selected an interior wall type. Exterior walls are drawn from the bottom of the first level
to the top of the highest level. Interior walls are drawn on just one level. In both cases,
they will be drawn from Level 1, because that is the current level (remember you
changed to the Level 1 view). If you changed to the Level 2 view, new walls will be
drawn at level 2 for their bottom and go up to Level 3 for their top. After a wall is drawn,
you can change the level that it is on and its height by selecting it and then clicking on
“Element Properties.” A dialogue box will appear that will allow you to make many
adjustments in wall height, vertical starting level and ending level.
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Put in some walls that look like this:
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Now let’s look again at the 3D view:

19.Go back to Level 1 plan.

20.Add the dimensions to the interior walls on the first floor
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21.Let’s put a floor under the first floor. Select the Home tab and select the “Floor”
tool. The drawing will dim and the instruction at the bottom of the screen will now
say “Pick walls to create lines.” Hover the cursor above the outside edge of the
top wall and then hit the TAB key on the keyboard; immediately click the left
mouse button. A purple line will appear all around the outside of the exterior
walls. You may need your instructor to show you how to do this properly. Be
patient.
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Now the purple lines go away and the floor has been drawn. You will not see the
floor in plan, but go to the 3D view and see it.



22.Return to Level 1 plan.

23.Let’s cut a section through the building. To do this, first select the View Tab:
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Then pick the Section tool. A cross-shaped cursor will appear. Pick a point on the left

side of the plan outside the exterior wall, then a point to the right side of that point, like
this:
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Click the mouse left button anywhere in a blank part of the screen to complete the
section creation. Now let’s look at that section. To do this, double-click on the arrow
part of the arrow- head on the left side of the section symbol. This will take you right to
the section view. The section looks like this:
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You can clearly see the floor you just created, as well as the level symbols and the
interior walls. The outer rectangle around the section itself is called a “viewport” in Revit.
It can be adjusted by clicking on it and moving one of the arrows that appears. Let’s try
it:
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Pull the left side arrow to the right about half way. This is how your section will

look now:
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Return to Level 1 Plan.

Notice that the section mark now looks like this:



EQ EQ EQ EQ EQ : EQ

4>

The blue dashed rectangular area above the section line has been shortened to
coincide with the viewport area that you changed in section. So there are two ways of
limiting the length of the sectional view: change the viewport in section, or change the
dashed lines associated with the section mark in plan.

24. Let’s create a stair to the second floor. Go to the Home Tab. Select the “Stairs”
tool.
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Pick two points to show the direction and length of the stair: pick the first point
at a location to the right of the first interior wall. Then move the cursor far to the
right and pick the second point. Your stair “sketch” will look like this:



This shows the stairs close up:
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It says “18 RISERS CREATED, 0 REMAINING.” This is a straightforward way of
making the stairs, but you can be fancier about it by picking a series of points while
“sketching” to allow you to turn the direction of the stairs or create landings. A little
practice is warranted to control the sketch creation.

Now to complete the stairs, select the “Finish Stairs” tool on the left side of the Ribbon.
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The completed stairs will look like this in plan:
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And like this in 3D:



The “Shading with Edges” was turned on to get it to look like this. The stair by default
has railings attached. These are separate objects and can be deleted or changed to a
different type if you wish.

25.Go to the Level 2 Plan. First put a floor in at this level. On Home tab, select the
“Floor” tool. Hover the cursor above the inside face of one of the exterior walls
and hit the Tab key on the keyboard, then left click the mouse. The purple lines
will be drawn around the interior of the exterior walls, like this:
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Now we need to cut a hole for the stairs to come through the floor. To do this,
select the rectangle on the Ribbo
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Draw a rectangle around the stairs to make a hole in the slab.



Click on the “Finish Floor” icon:
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You will get a dialogue box asking you if you want the walls that are below this floor to
attach to the bottom of the new floor. Select “Yes.” What that will do is stop the tops of
the wall below the floor thickness, no matter how thick the floor will be. If you answer No
to this dialogue, the floors will remain attached to the Level 2 plane and thus penetrate
through the floor.



Would you like walls that go up to this floor's
level to attach to its bottom?

Next you will be asked if you want the floor to cut into the thickness of the exterior
walls.

The floor/roof overlaps the highlighted wall(s).
Would you like to join geometry and cut the
overlapping volume out of the wall(s)?




In this case answer by selecting the “No” button.

The floor will now be created. To see how it looks in section, double-click the

section arrow head:
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The section view will

now appear:
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26.Now we are ready to put on a roof.

Select the Level 2 Plan on the browser. On the Home tab, select the Roof

tool:
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Hover the cursor over the exterior face of one of the walls and hit the Tab key to
select all the walls, then click the left button of the mouse. You will get a purple
line drawn around the walls 2’.0” away from the walls (this will be the roof
overhang):



Click the Finish Roof icon on the Ribbtan:

' | | Cut | G |
Scale | - i *;'_?-: J x
Delete | Paste S Roof | Fimish Cancel
Aligned ~ Paste ‘ Properties | Roof  Roof
Clipboard l Element | Roof

You will then see a dialogue box asking you if you want the exterior walls to

attach to the sloping roof. Select the Yes button:
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Would you like to attach the highlighted walls to
the roof?

The roof will be formed and look like this in plan:

It is an odd appearance, but it is rational because the plan view is cut 4’.0”
above the floor level. If you go to the section view, it will look like this:
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Now let’s look at a 3D view:






Here it is with shadows turned on:




Here is a rendered view:

27.When you look at the Level 2 Plan you may notice that you can still see the walls
below, even though there is a floor now at Level 2 and the walls stop below the
floor. This is because level 1 “Underlay” is turned on by default. The “underlay”
is a very useful tool because it allows you to see the walls below when you are
creating walls on a floor above. You can turn it off. Here’s how:
Go to Level 2 Plan. Right-click the mouse to bring up a menu; select “View
Properties.” Now this dialogue box will appear:
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Note that in the “Underlay” row, the words “Level 1” appear. That means that the
underlay drawing is Level 1 Plan. You can turn it off by selecting the words Level 1
and a drop-down menu appears giving you a choice of various plans to show as an
underlay, including one called “None.” Select “None” and then see that the walls on
the first floor are no longer showing as faded out lines on the second floor.
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Pick OK.
Now the Level 2 Plan will look like this:



Pretty good except the stupid roof is still showing up on the Level 2 Plan. Let’'s
take care of that now too. You can turn off any element in any view in two ways.

The first way is a temporary way, which lasts only for the duration of the drawing
session, the second way is permanent until you turn it back on again. Let’s look at
both of these methods. First the temporary method. At the bottom of the screen is the
“View Control Bar:”
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There is an icon on this bar that looks like a pair of glasses. To turn off any object in
the view you are in, first select the object and then click on the glasses and pick
“Hide Element.”

When you pick the roof with your left mouse button, it will turn blue:



If there were more than one object that you wanted to hide, you could add objects to the
selection set by holding down the <Ctrl> key and continuing to pick. Not that the <Ctrl>
key will place a + sign next to the mouse cursor, meaning that you are adding objects.
Conversely, if you want to remove objects from a selection set, hold down the Shift key
and pick the objects you want to remove. Now pick the glasses icon and select “Hide
Element.” Here is how it will look after you hide the roof:

Note that there is a light blue line around the screen. That is a visual clue for you to let
you know that something is hidden in that view. If you cannot remember what you hid,
simply pick the light bulb on the right end of the View Control Bar. Note that objects
that are temporarily hidden will print.
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The hidden objects will show up in a faded light blue color, like this:

To turn hidden objects back on, select the glasses icon again and pick “Reset
temporary Hide/lsolate.”

The second method of turning off objects in a view is to right click on an object and
select “Hide in View” > “Elements.” Once again, you can use the light bulb toggle in the
View Control Bar to show the hidden elements — this time they are shown in a faded
purple color, to distinguish a permanent hide from a temporary one. So it will look like
this:
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To turn hidden objects back on, right click on the purple object that is visible when
the light bulb is turned on and select “Unhide in View”> “Elements.” Then turn the
light bulb off.

Objects that are permanently hidden will not print.

28.Let’s add a wall on the second floor to create a room. On the Home tab, select
the Wall tool. Draw a wall on Level 2 and put a door in it, like this:

Go to a 3D view:

You can see the wall sticking up above the roof.



To fix this, click on the wall, and select “Attach” tool on the Ribbon, then pick the roof to

attach them to.

ing & Site  Collaborate

EJT Attach Bl M

J| Ed# — | Move Copy S
Profile D4 Detach oo A
| ModifyWall | Modit

Here is how the 3D view will now look:



Go back to Level 2 Plan and double click on the section arrow. Here is how it will look in
section:
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29.We need to put some doors on the first floor, too. Go to Level 1 view. Make
sure that “Tag on Placement” is turned off and then select locations for doors
into the rooms. Your drawing should look like this:
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30.Next, we will explore the “I” of BIM (Building INFORMATION Modeling). We will
start by placing room tags in all the rooms.

On the Home tab, select the “Room” tool:
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Place a Room gismo in each room, so the Level 1 Plan should look like this:

Level 2 Plan should look like this:
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Now rename the rooms by double clicking on each word “Room” and typing in the new

name:
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31.Revit keeps track of everything about the rooms and can produce a room
schedule showing that information. Let’'s make a room schedule. On the View
tab, select the “Schedule” tool pulldown, then “Schedules/Quantities.” The

following dialogue box wi
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Scroll down in the Category list and select “Rooms.”




Category:
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Name:
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Click OK.

The “Schedule Properties” dialogue box will appear. From the “Available Fields” list,
select the following fields and click on the “Add --->” button after each one.

Number
Name

Level

Area
Perimeter
Floor Finish
Base Finish
Wall Finish
Ceiling Finish
Unbounded Height
Comments

The Schedule Properties should now look like this:




Now click OK and your schedule will be created:
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3l Room Schedule
- Number Name Level Area i Perimeter | Floor Finish | Base Finish | Wall Finish : Ceiling Finish | Unbounded | Comments
1 Foyer Level 1 111 SF 42 - 1" 10°-0"
2 Living Room Level 1 1363 SF 199°-1" 100-0°
3 Storage Level 1 146 SF 48 -4 10°-0"
4 Bathroom Level 1 76 SF 36 -4 10°-0"
S Rumpus Room Level 2 1245 SF 143'-7" 10°-0"
6 Bedroom Level 2 483 SF n-r 10°-0"

You can fill in the blank cells with the Floor, Base, Wall and Ceiling Finish materials
and any comments you may want to include, such as “SLOPED CEILING.”

32.Finally, let’s put everything together onto drawings to send out to bid or
construction. In the browser, find the item down toward the bottom called “Sheets
(all).” Right click on it and select “New Sheet.” A sheet titleblock selection box will
appear. Click “Load” and load the D-sized title block from the Titleblock folder in
the Imperial Library. A blank sheet will appear that looks something like this:
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To put drawings on the sheet, simply drag them one at a time from the browser to the
sheet:

Drag the Level 1 and Level 2 plans onto the sheet you just created. They will come onto
the sheet complete with titles. The viewports will be large, but they will not print. You will
need to move the titles up a bit under each plan and shorten the line under the title
name. To move the view title on the sheet, just click on it with the left mouse button,
hold the button down and move to where you want it. To shorten the line under the title,
click on the viewport (not the view title). A dot will appear on the right end of the line.
Hold the left mouse button down on the dot and drag it to where you want it to be.

Note that the elevation tags will show up too far away from the plans and will get in the
way of the other views you want to put on the sheet. To fix this, go back to Level 1 plan
and then level 2 plan and drag the elevation marks closer to the exterior walls on each
side. Here is how the Level 1 Plan looks before moving the tags:
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To move an elevation key on a plan, first put a window around the whole key and
select the “Move” tool.
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After moving the elevation keys, the Level 1 plan should look like this:

|
|
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Elevation keys on the Level 2 plan will automatically be moved to the same locations
as on the Level 1 plan.

Now go back to the Sheet view. It will look better:
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Now drag the West and South Elevations onto the Sheet.

Move their view titles and shorten the line under the title names just like you did for the
plans:
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Now drag the Section and Room Schedule onto the Sheet:

Here is the finished sheet:
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Note that you can create as many sheets as you want using the same process.
Every drawing view put on the sheet will be given a number automatically and the
tags for Elevations and sections will be shown on the sheet: Zoom in to one of the
title numbers:

For example look at the Section title on the sheet:
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Now look at the head of the section key on the plan on the sheet:
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Note that the number of the section and elevation detail on the sheet has been
assigned, as well as the number of the sheet on which they appear. If you move the
section to another sheet, for instance, the sheet number on the tag will be
automatically changed. Revit will not allow you to place a view on more than one
sheet.

So here is your final sheet:
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